OptiSurface Designer Release Notes

This document contains release notes for OptiSurface Designer (OSD) Software. Information in this document is more current than that in the manual.


Version 2.5.10


26 October 2016

New Features and Improvements:

  • OptiLine.  Breaklines can now be designed to create an OptiLine with variable slopes, just like OptiSurface1Way.
  • Breakline Improvements.  Added Flip Breakline and Split Breakline operation and the profile shows the Proposed Topography as well.
  • Batter Breakline.  Improved how Batter Breakline operation functions.
  • Cut/Fill Map.  Improved triangulation. Max cut and max fill points are now shown in the Cut/Fill Map.
  • Irrigation Analysis.  NRCS Intake Family formula is now supported in Irrigation Analysis.
  • Main Slope Arrow.  Main Slope Arrow size can now be adjusted in Project Properties.
  • Design Zones.  Drawing zones snaps on 15 degree increments and snaps on points/vertices as well.  Zone names are now centered.
  • Annotation. Annotations are now saved layers (maps).
  • Measure Tool.  Measure tool can now be clicked outside the maps.
  • Trimble Export (.gps). The FMX seemed to offset the design by one grid cell in firmware version before 9.25.  The .gps export will no longer shift by one grid cell.
Fixes:
  • OptiSurface2Way.  Max Main Slope now applies properly to reverse (negative) side of the ridge.
  • Views Locked.  Fixed issues when exporting the control file sometimes says 'Views Locked' even if it was already unlocked.
  • Master Benchmark.  Importing multiple surveys with non identical MB will now have an option to use only one MB.
  • Ponding Results.  Results do not show losses if there are no ponding calculated.
  • Background Image.  No image is imported if MB Coordinate is set to 0, 0 (latitude, longitude).
  • US Feet Issues.  Calculate Storage Depth and Calculate Flow issues with US Feet units now fixed.
  • Design Report.  Zones and Main Slope Arrow sometimes not showing in Design Report now fixed.
  • Runoff Velocity Map.  Fixed the issue where Runoff Velocity Map is always turned ON.

Known Issues:

  • OptiLine. Designing a Breakline which extends beyond the boundary line will not work.  Batter Breakline for OptiLine also needs improvement.
  • Mass Balance Optimisation. Not setup yet.


Version 2.4.21


05 April 2016

Minor Fixes:
  • Edit Boundary. Fixed an issue where OSD sometimes crashes when editing or splitting the boundary.
  • Runoff Velocity Map. Fixed an issue where the Runoff Velocity Map sometimes became permanent and does not disappear even when ticked OFF.

Version 2.4.20


20 January 2016

New Features and Improvements:

  • Unlock Landform Design.  Cut/Fill Map is now unlocked for FREE after landform design calculation to evaluate landforming feasibility without paying (unlocking) first. Need to unlock Proposed Topography map still before exporting.
  • Cut/Fill Map.  Improved Cut/Fill map to include survey points in triangulation for a more accurate calculation of earthworks.
  • Recalculate Cut/Fill.  Improved Recalculate Cut/Fill dialog and calculation process for more accurate earthworks.
  • Cross/Main Slope Ratio.  Included this parameter in landform design to limit cross slope relative to mainslope.
  • Design Zones.  Improved visibility when editing design zones.
  • Edit Points (Polygon Select).  Added new option to draw a polygon to edit or copy points.
  • Breaklines.  Added option to use curved breaklines instead of just straight lines.
  • Profile.  Option added to draw a polyline to view the topography along a path.
  • Slope Maps.  Improved slope maps using triangulation instead of smooth surface to better represent the slopes.
  • Boundary.  Boundary line can now be split into two with the straight splitting line snapping on selected point of the boundary.
  • Irrigation Analysis.  Experimental new feature to calculate furrow irrigation efficiency and optimize.
  • Runoff Analysis.  Added infiltration parameter USDS SCS Runoff Curve Number.  Also added Inflow for subzone parameter defining water volume coming in from watershed into the field.
  • Drainage Subzones.  Valley subzones can now be used to represent cross drains that cut across furrows in Drainage Analysis.
  • Export to OptiSurface Cloud.  New feature to export the design report to cloud storage hosted by OptiSurface to send designs to clients.  Client can add point of interest and add comment for better feedback.
  • Background.  Improved how background image is imported and added option to change transparency.  Now allows multiple images from Google Maps to cover large fields.
  • Image Drape.  Added new option under Existing Topography in Project Explorer which drapes the aerial photograph over the Existing Topography. Can also import any image for reference, eg yield maps.
  • Benchmarks.  Transferred benchmarks to their own project explorer item so they can be kept visible.
  • Zoom to Extents.  Now zooms to the boundary instead of including the background for the extents.
  • Reports.  Reports can now be created for landform design, drainage analysis, runoff analysis and storage volume separately. Grid Report is now optional for Landform Design Report.
  • Export Landform Design.  Added option to export subzones and breaklines.

Fixes:

  • Editing Subzones.  Fixed the issue with editing the subzones, now subzones can be edited without needing to zoom out to click a point in the subzone.
  • Adding Subzones in Cut/Fill Map.  Existing Topography no longer overlays the Cut/Fill Map when adding a new zone.
  • Map Grid.  Now shows correct 300ft distance when using US Feet Units.

Known Issues:

  • Mass Balance Optimisation. Not setup yet.

Version 2.3.14

21 Oct 2014

New Features and Improvements:

  • Unlock Cost.  Cost to unlock a field adjusted down.
  • Surface Type.  Added OptiSurface 1Way Circle and OptiSurface 2Way Circle to support circular furrow designs for pivot fields.
  • OptiSurface Cloud.  New feature, OptiSurface Cloud, hosts images and design report for consultants to share their design with their clients online.
  • Storage Volume.  New feature to calculate reservoir storage volume at various depth.
  • Cross Slope to Main Slope Ratio.  Added a Special Function in Landform Design to set maximum cross slope to main slope ratio; RATIO0.5, RATIO1.0 and RATIO2.0.
  • Background Map.  Background image now centers where the Map Window is centered and not on the Master Benchmark.
  • Breakline.  Added new functions for breakline: Copy, Move, Offset and Batter. 
  • Export to Shape File.  Option to export to shape files (.shp) is now functional.
  • Re-calculate Cut/Fill.  Improved Re-calculate Cut/Fill and added options to adjust breaklines when Rebalance Cut/Fill Ratio is ticked ON.
  • Design Report.  Included Cut/Fill grid report.
  • Annotations.  Added an option to change the text size of annotations like text boxes, etc.
  • Backwards Compatible.  Files saved in OSDv2.x can now be opened using OSDv2.3.8 and above, but files saved in OSDv2.3.8 cannot be opened using lower versions.
Fixes:

Known Issues:
  • Editing Design Zones.  Design zones are difficult to edit because the vertices are not easily highlighted.  The first point of the design zone is always highlighted when zoomed in, try and zoom out until the vertices can be highlighted in red.  Click that point and zoom in using the mouse wheel (while holding the point) to edit and move the point with more precision.
  • Trimble Update.  Trimble recently released Firmware V8.02 addressing several issues including a one grid cell horizontal offset problem in the control file.  In OSDv2.2.x, we shifted the control file one grid cell in mainslope direction to compensate for this problem.  In OSDv2.3, we shifted it back to coincide with Trimble releasing firmware (v8.xx), which fixed this problem.  Unfortunately, the Firmware V8.02 has some other issues and is not widely available.  The best workaround to this issue is to use OSDv2.2.7 for now until Trimble get v8.xx fully released.  For designs with maximum slopes less than 1% this problem is barely noticeable especially when exporting on a small grid (eg 2.5m, 10ft).
  • Mass Balance Optimisation. Not setup yet.


Version 2.2.1

17 January 2014

New Features and Improvements:

  • Design Zones.  New zones will be categorized into New Subzone or New Boundary.  New Subzone functions the same as before, but subzone now automatically changes color according to type, ie. red for Ridge, blue for Valley.  New Boundary allows calculation of areas independently, best used when designing multiple fields that are adjacent to each other.  Zone names are now shown in the Map Window.
  • Landform Design.  Landform Design Properties is now integrated with Design Zone Properties for easier access and adjustments of parameters.  Surface designs are calculated one boundary at a time.  Improved Design Summary to include Cut/Fill Table.
  • Smoothing Distance.  Smoothing Distance (ft/% or m/%) now replaces Max . Change (%/ft or %/m). The convention of 0.01 %/m is now 100 m/%.
  • Surface Type.  Changed OptiSurface1D to OptiSurface1Way, OptiSurface2D to OptiSurface2Way and OptiSurface4D to OptiSurface4Way to avoid confusion with 3D (3-dimension).  OptiSurface4Way now allows changes in cross slopes parameters.
  • Contours.  Contour legend does not show the elevation range for each color but instead shows the overlap value for adjacent colors.  Also added contour interval below the legend.
  • Main Slope Arrow.  Improved main slope arrow to show where the negative and positive cross slope lies to improved design experience.  Main slope arrow for OptiSurface4Way remains the same.
  • Project Explorer.  Maps can now be overlapped to improve design and analysis experience.
  • Drainage Analysis.  Improved Ponding Map color scheme and now allows overlay of Flow Paths Map (previously Catchment Area).  Drainage Analysis Summary is also improved to show ponding statistics by depth.
  • Runoff Analysis.  Improved Runoff Depth Map and Runoff Velocity Map color scheme and improved arrow directions. 
  • Profile.  The long section and cross section is now replaced by Profile, the reference line is more flexible and can be shifted to any part of the field or rotated to any bearing.  
  • Breakline.  Improved breakline appearance and expanded editing options.  The profile of the breakline will now show if the user wants to edit the line.
  • Project Properties.  Project properties now include Datum and Coordinate System.
  • Background.  Background images imported from a file or Google Earth can now be added to the Map Window to aide in adding references to ditches and other features already present in the field.
  • Show In.  The map window can now be imported to Google Earth and Google Map.
  • Export Image.  Map images can now be exported as Google Earth Image Overlay (kml), Portable Network Graphics Image & World File (png and pgw) and Windows Bitmap Image& World File (bmp & bpw).
  • Design Report.  Design Report now includes the images of the Maps including the Existing Topography, Proposed Topography, Cut/Fill Map, Down Slope Map and Cross Slope Map.
  • License\Credit Status.  The license status or credits remaining in the license can now be viewed by the user.  Added other functions such as purchase, activate or transfer the license.
  • Mark-up Text.  A new tool bar is added and will allow marking up or adding text to the Map Window.
  • Drawings.  Drawing Mode is added to enhance designing experience of the user.
  • Open File.  Open File can now also function as Import Topography.
  • Autobackup.  Changed backup file name to * Backup.osd eg MyDesign01.osd will autobackup to MyDesign01.osdbac.  If osd crashed while working on MyDesign01.osd, upon re-opening MyDesign01.osd, OSD will ask if the user wants to load the back up if it is more recent.
  • Getting Started.  Added Getting Started Window to help beginners learn quickly and get up to speed.
  • OptiSurface Support Center.  User can now visit OptiSurface Support Center by going to Help > Visit OptiSurface Support Center to make it easier for users to access the Knowledge Base, Feedback Forums and Email for support requests.
  • Minimum Field Area.  New minimum field area 6 hectares or 15 acres.  If the field for unlocking is less than the minimum, OptiSurface Designer will charge 59 credits.
Fixes:
  • Export Landform Designs to Trimble .gps Files.  In V1.4.5 some exported .gps files were not visible in the file list when attempting to load them in the Trimble FMX. This issue has now been fixed.
Known Issues:
  • Mass Balance Optimisation. Not setup yet.



Version 1.4.6

26 Jun 2013

Fixes:

  • Export Landform Designs to Trimble .gps Files.  In V1.4.5 some exported .gps files were not visible in the file list when attempting to load them in the Trimble FMX. We have reverted to the OSDV1.3.3 routine for now until a fix is found. However, this routine does not export any boundaries or subzones.

 

Version 1.4.5

20 Nov 2012

New features and improvements:

  • Smoothing Factor (Max Slope change) more flexible. User will be able to calculate a design with almost any smoothing setting. A less messages saying a design could not be calculated.
  • Credit Deduction Process. Now you pay once to unlock the view, and you DO NOT have to pay again to re-calculate or export the field. The only thing that changed is when you pay: now it's after the calculation not when you export.
  • File Loading Progress Messages. The progress of the file loading is indicated by text updates in the dialog box which can be useful when loading large files.

Fixes:

  • Export Grid Rotation To Trimble .gps Files. For some angles the grid was not displaying in correct location on the Trimble FMX. Any rotation angle now works.
  • Long And Cross Sections - Autobackup Clash. Sometimes the section view could get locked if the autobackup was triggered.

Known Issues:

  • Tools>Recalculate Cut/Fill. Can produce negative grades near the  boundary under certain conditions such as when the cross slope is large and the recalculate grid is different to the original OptiSurface calculate grid.
  • Mass Balance Optimisation. Not setup yet.

Highlights Video:

 

Version 1.4.2

19 Sept 2012

New features and improvements:

  • Support US units.    Option to work in US feet
  • More Contours.    10 contours/isolines for each colour band gives more detail in surfaces
  • Import APEX export file.     Able to import csv text files that John Deere's APEX software exports.  File type in Open dlg is: John Deere APEX Export (*.csv)  
  • Import of AGPS survey files.    Able to import text files that AGPS software exports. File>Import or Open >'AGPS Survey File (*.ags) ' 
  • Export 'AGPS Design File'.     Able to export designs to a AGPS Design File. File>Export Proposed> Save As Type 'AGPS Design File (*.agd) ' 
  • Mainslope Arrow.    Arrow where the main slope direction is.
  • Triangulation Speed Up.  Faster for to handle large data sets eg 100,000 points.    
  • Export boundary, subzones and Breaklines.     Allows ability to see zones and breaklines in the earthmoving equipment
  • Benchmark Report.    Benchmark information are displayed on the design report.
  • Drainage analysis of proposed design.    Able to calculate the drainage analysis on the proposed topography as well as the existing topography 
  • Show Field in Google Maps.    Add Tools>See Google Map menu item
  • Handle larger XYZ number.    OSD currently handles larger X,Y & Z coordinate values by introducing an offset or base during import.
  • Improve File Saving.    Forces user to save osd file to ensure credits transactions are recorded.
  • Autobackup name.    Change backup file name to * Backup.osd eg MyDesign01.osd will autobackup to MyDesign01 Backup.osd.
  • Autobackup Improvements. Tools>Options>General Auto Backup Interval (min): 10  plus other improvements
  • Delete breakline.      Right click delete breakline . Added "Are you sure you want to delete the breakline?" 
  • Master Benchmark Editable.    Display this in the project properties to add it/change it if required. Careful however. 
  • Swap zoom mouse roll direction.    To match other software like Google Earth/Autocad. 
  • Boundary & Subzones Zone Remove Limits.    Able to draw the boundary extent and subzone extents off the surface so that I dont have to try to carefully draw around the edge of the surface and for other reasons.  
  • Improved Runoff & Drainage Direction Arrows.  Able to see the drainage and runoff direction arrows betterto understand the flow directions better.
  • Show design Zones along with Proposed Surface.    After calculating the proposed Surface operation, the proposed surface is displayed (ticked in project explorer).
  • Remove warning no Valley-Ridge in Optisurface 2D.   
  • Label sizes.    Improved default label sizes for existing topo   
  • Locked Views. All calcuations can be carried out for free and summary results are displayed along with surfaces as a single colour. You can 'unlock' the views with OptiSurface credits. 

Fixes:

  • Status bar values incorrect in subzone.    Cursor inside a subzone the status bar displayed values incorrectly.
  • Highest Contour was not interpolated properly. Appeared jaggard. Cosmetic problem only.
  • Save & Close crash.    Trigger Save and then press close (X) button too soon before save is complete it could crash the program and lose the osd file. 
  • Export & Exit crash.    If you Export a design and before the export is finished you press exit button you could get a crash.
  • Subzones merge.    Subzones merged sometimes when you create a new subzone. ie it shares the name and properties with an already existing subzone. 
  • Vertical Exageration Factor.   The Vertical Exageration Factor that was stored in the Project Properties was rounded"
  • Some Survey Files wouldnt open.    Intermittent bug when opening and importing survey files (xyz, txt).
  • Some Subzone Properties not being applied properly.     When subzone moved out side boundary, properties were not being applied correctly.

Known Issues:

  • Tools>Recalulate Cut/Fill. can produce negative grades near the boundary under certain conditions such as when the cross slope is large and the recalculate grid is different to the original OptiSurface calculate grid.
  • Mass Balance Optimisation. Not setup yet.

 

Version 1.3.2

18 Aug 2011

New features and improvements:

  • Removed charges for calculating landform designs. Only get credits consumed when you export the design now. 
  • Reduced charges for Drainage Analysis.
  • Displaying positive and negative slopes for OS2D and OS4D designs.

Fixes:

  • Some computers could not install and run the software. Fixed memory bug.

Known Issues:

  • Status Bar XYZ Indicator Not Updating when cursor is in a Subzone.
  • Triangulation Problems: Triangulated mesh is messed up in some circumstances. Mainly visual effect.
  • Highest Contour not interpolated properly on most surfaces. Appears jaggard. Cosmetic problem only.
  • Tools>Recalulate Cut/Fill can produce negative grades near the boundary under certain conditions such as when the cross slope is large and the recalculate grid is different to the original OptiSurface calculate grid.
  • Mass Balance Optimisation is not working yet.
  • Subzones mishaving: Somtimes not applying design parameters across whole subzone. Workaround: Create a new subzone with same outline and parameters as problem subzone. then Delete problem subzone. 
  • Breaklines misbehaving: Sometimes breaklines lose some of their internal points whihc means the triangulation to them doesnt work properly. Workaround: Right Click on the breakline and select properties, then adjust point spacing a small amount and click OK. Check triangulation to breakline is OK (turn on wireframe for topographic surface by right clicking on 'Topography' in Project Explorer Tree and then click properties, then wireframe tickbox then OK.). If still having problems try restarting your computer to free up more memory.

 

Version 1.3

6 Jun 2011

New features and improvements:

  • OptiSurface2D Designs Valleys and Ridges. One or more valleys and/or ridges are now possible in an OS2D design. Use subzones to define the valleys and ridges using the 'subzone type setting'.  
  • Extention of points outside calculation area: Improved how the edge points are extrapolated. It now uses slope from inside two points.
  • Export Proposed includes a recalculation of the export grid to allow a finer more accurate grid and a different rotation.  
  • Infeasable Constraints: Improved OptiSurface 2D and 4D calculations engine by over riding user defined constraints in valleys and ridges which were infeasible due to max slope change being exceeded when minimum slopes switched directions. 
  • Calculating dialog box added while drainage analysis is calulating.
  • Menu shuffle. 'Edit' menu items shifted in to 'Tools' menu to make it more obvious.

Fixes:

  • Modify Sub zone Extent: After the user modified the a subzone extents the calcuation results were not right.
  • Subzone Delete: Whe the user deleted a subzone, closed the files and reopend it the subzones numberings were messed up.
  • Balance Earthworks Within Subzones: A bug prevented more than one subzone
  • Runoff Analysis: Areas of deep still water were displaying higher velocities than expected due to instability of solution. Have improved the solution.  
  • Export proposed design after opening osd file would cause OSD to crash. 
  • Improved Drainage Analysis feature that allows you to see the impact of furrow/raised beds on ponding depth and flow paths over existing topography - good to show benefits for Optisurface Landforming
  • New Balance Earthworks Within Subzones as well as whole field - Allows you to reduce haul distances by preventing long carts from one end of the field to the other.
  • New Optisurface Design Parameters such as Maximum Allowable Fill Depth, Minimum Allowable Elevation - allows you to have more control over the design surface.
  • Prompts to save file after export, drainage analysis, runoff analysis. 
  • Breaklines shifted dramatically when edited. Have swithced to orthographic projection by default to prevent this.
  • Backup file was not working properly. After opning an osd file would get a warning the backup is available even though OSD did not crash.
  • Recalculate CutFill did not only use area within boundary zone for calculation points 
  • Import large xy values produce problems with calculations. Eg 9999.99 is the largest number possible
  • Export Proposed: Didnt work properly after Recalc Cut Fill. "Export Proposed MessageMessage is wrong: http://screencast.com/t/Ts2ifEXcT5"
  • Update Current Directory: Update Current Directory to where the user navigates.
  • Turned off 'snap to points' when adding or modifying boundary and subzones. This was causing problems when trying to follow the boundary closely.  
  • Subzone TickBoxs: Some tickboxes were not working properly. 
  • Subzone Radio buttons: The Zone type radio buttons were not stying on properly. 
  • Highest Contour not interpolated properly: Fixed in existing topography surfaces but not in other surfaces. 
  • Breaklines made large files really slow to open.
  • Disabled Graphic hardware acceleration by default to improve stabilty. See Tools>Options.
  • Max. triangulation length valid range from 1 to 1000 to 1 to 10000
  • Max. allowable Vertical exaggeration factor to 100 
  • Changed backup file extension from osdbac to .osdbackup when saving 
  • Subzone minimum elevation property not working properly

Known Issues:

  • Status Bar XYZ Indicator Not Updating when cursor is in a Subzone.
  • Triangulation Problems: Triangulated mesh is messed up in some circumstances. Mainly visual effect.
  • Highest Contour not interpolated properly on most surfaces. Appears jaggard. Cosmetic problem only.
  • Tools>Recalulate Cut/Fill can produce negative grades near the boundary under certain conditions such as when the cross slope is large and the recalculate grid is different to the original OptiSurface calculate grid.
  • Mass Balance Optimisation is not working yet.

 

 

Version 1.2

02 Nov 2010

Minor backend changes.

 

Version 1.1.1

14 August 2010

New features and significant improvements:

  • New Runoff Analysis feature that allows simulation of water depth and velocity - for examining erosion hotspots
  • New Edit Proposed Topography with points and breaklines - allows you fine control over the design surface eg draw in contour banks, create gully dam embankment, draw cross drain
  • Improved Drainage Analysis feature that allows you to see the impact of furrow/raised beds on ponding depth and flow paths over existing topography - good to show benefits for Optisurface Landforming
  • New Balance Earthworks Within Subzones as well as whole field - Allows you to reduce haul distances by preventing long carts from one end of the field to the other.
  • New Optisurface Design Parameters such as Maximum Allowable Fill Depth, Minimum Allowable Elevation - allows you to have more control over the design surface.

Known Issues:

  • Licence Activation screen is freezing at certain points. Workaround is to end the application with Windows Task Manager or reboot the PC.
  • Mass Balance Optimisation is not working yet.

 

Version 1.0

16 Dec 2009

First official release.

 

Version 0.996

30 Sept 2009

Second Beta Release.

 

Version 0.92

24 May 2009

Initial Beta Release.

Major issues with this release that are known are:

  • OS 2D is not working.
  • Fine calculation grids are causing errors. A dialog box will warn when this occurs.
  • Some Design Results in Design Report are not correct.



Feedback and Knowledge Base